Как правильно перейти с php7.0 на php7.1?

В данной категории, пользователи задают вопросы относительно установки и эксплуатации MOGUTA.CMS
lvl 6
Аватара пользователя

Прогресс до следущего звания:
30%
Сообщения: 79
Зарегистрирован: 30 сен 2017, 12:11
СообщениеДобавлено: 10 мар 2018, 12:54
Сейчас сайт на php7.0. У хостера появилась поддержка ionCube Loader под php7.1. Собственно вопрос, как правильно сделать переход? Попробовал сменить версию php на тестовом сервере, админка работает, а сайт не отображается. Ошибок в логах нет. Хостер Бегет, уверяет, что поддержка ionCube Loader под php7.1 есть.
Web-мастер
Аватара пользователя

Сообщения: 1071
Зарегистрирован: 31 янв 2016, 20:35
СообщениеДобавлено: 12 мар 2018, 17:05
Автоматически движок меняет версию php для себя.
Но рекомендую использовать 7.0.
lvl 6
Аватара пользователя

Прогресс до следущего звания:
30%
Сообщения: 79
Зарегистрирован: 30 сен 2017, 12:11
СообщениеДобавлено: 14 мар 2018, 10:04
AndreySupport писал(а):Автоматически движок меняет версию php для себя.
Но рекомендую использовать 7.0.

Почему 7.0? В чем проблемы с 7.1?
lvl 6
Аватара пользователя

Прогресс до следущего звания:
30%
Сообщения: 79
Зарегистрирован: 30 сен 2017, 12:11
СообщениеДобавлено: 16 мар 2018, 11:18
Автоматического перехода на версию 7.1 не произошло. Все так же, админка работает, а клиентская часть не открывается. В логах ошибок нет. Подумал, что может хостер пошутил о поддержке лоадера с 7.1. Скачал нужную версию могуты, поставил все с нуля и все работает. Значит хостер не обманул о поддержке. Вопрос остался, как перенести рабочий сайт с 7.0 на 7.1 без заморочек? И так и не получил ответ почему лучше остаться на 7.0? В чем причина?
Web-мастер
Аватара пользователя

Сообщения: 1071
Зарегистрирован: 31 янв 2016, 20:35
СообщениеДобавлено: 19 мар 2018, 13:59
Без заморочек просто изменяете версию php на сервере.
Серьёзных отличий между 7.0 и 7.1 нет, как и нету смысла изменять версию.
lvl 6
Аватара пользователя

Прогресс до следущего звания:
30%
Сообщения: 79
Зарегистрирован: 30 сен 2017, 12:11
СообщениеДобавлено: 20 мар 2018, 13:31
В том то и дело, поменял версию на сервере и сайт ложится.
Web-мастер
Аватара пользователя

Сообщения: 1052
Зарегистрирован: 12 фев 2014, 21:57
Откуда: Екатеринбург- Краснодар
СообщениеДобавлено: 25 мар 2018, 14:34
AndreySupport писал(а):Без заморочек просто изменяете версию php на сервере.
Серьёзных отличий между 7.0 и 7.1 нет, как и нету смысла изменять версию.

Андрей, каким образом Вы шифровали файлы для php 7.0? На сайте иона не нашел такой возможности... Есть все, 7.0 - нету(((.
lvl 6
Аватара пользователя

Прогресс до следущего звания:
30%
Сообщения: 79
Зарегистрирован: 30 сен 2017, 12:11
СообщениеДобавлено: 26 мар 2018, 09:41
Короче, отложил в сторону бубен и остался на версии 7.0.
Web-мастер
Аватара пользователя

Сообщения: 1071
Зарегистрирован: 31 янв 2016, 20:35
СообщениеДобавлено: 10 апр 2018, 14:45
Yuricson писал(а):
AndreySupport писал(а):Без заморочек просто изменяете версию php на сервере.
Серьёзных отличий между 7.0 и 7.1 нет, как и нету смысла изменять версию.

Андрей, каким образом Вы шифровали файлы для php 7.0? На сайте иона не нашел такой возможности... Есть все, 7.0 - нету(((.

Подходит шифрование от php 5.6 для php 7.0
Web-мастер
Аватара пользователя

Сообщения: 1052
Зарегистрирован: 12 фев 2014, 21:57
Откуда: Екатеринбург- Краснодар
СообщениеДобавлено: 12 апр 2018, 08:46
Подходит шифрование от php 5.6 для php 7.0

Спасибо, уже выяснили))))
След.

Вернуться в Помощь пользователям от пользователей