Пустая страница после создания заказа

В данном разделе пользователи описывают найденные ошибки и неисправности системы.
lvl 1
Аватара пользователя

Прогресс до следущего звания:
0%
Сообщения: 1
Зарегистрирован: 21 дек 2016, 11:14
СообщениеДобавлено: 21 дек 2016, 11:44
показывает пустую страницу после создания заказа (order?creation=1) если пользователь не имеет админских прав.

1) письмо на подтверждение уходит
2) заказ создаётся
3) страница вообще пустая, т.е. я так понимаю что до layout и view дело не доходит
4) если пользователь с правами админа, то показывается страница с просьбой проверить почту.
5) версия CMS на данный момент последняя. v6.9.5
6) пустая страница появляется независимо от выбранных доставки и оплаты.

В общем пишу сюда потому что просмотрел код где только мог сначала думал что в шаблоне проблемы, но и на дефолтовом шаблоне поведение такое же

Помогите найти проблему пожалуйста!
Web-мастер
Аватара пользователя

Сообщения: 626
Зарегистрирован: 31 янв 2016, 20:35
СообщениеДобавлено: 29 дек 2016, 19:57
А в плагинах искали проблему?
lvl 1
Аватара пользователя

Прогресс до следущего звания:
0%
Сообщения: 1
Зарегистрирован: 15 мар 2017, 17:22
СообщениеДобавлено: 15 мар 2017, 17:35
Давняя проблема, но разработчики на нее видимо забили!
Причиной такой работы является сжатие js и CSS.
Если закомментировать в core/lib/mg.php сжатие js, то как-то работает, но при ордере стирается кеш кроме картинок и шрифтов.
Это на движке 6.9.8 с темой default.
Уже не надеюсь, что сжатие приведут в норму.
lvl 3
Аватара пользователя

Прогресс до следущего звания:
93.3%
Сообщения: 29
Зарегистрирован: 19 окт 2015, 09:45
СообщениеДобавлено: 18 май 2017, 21:31
Аналогичная проблема.
В чем может быть дело? как поправить?
lvl 3
Аватара пользователя

Прогресс до следущего звания:
93.3%
Сообщения: 29
Зарегистрирован: 19 окт 2015, 09:45
СообщениеДобавлено: 19 май 2017, 00:15
Обновление всех плагинов решило проблему. Из за какого именно плагина была проблема не знаю.
Web-мастер
Аватара пользователя

Сообщения: 626
Зарегистрирован: 31 янв 2016, 20:35
СообщениеДобавлено: 08 июн 2017, 19:22
В данной проблеме виноват какой-то плагин, либо шаблон.
Отключите плагины и выявите, какой виноват.

Вернуться в Баги